Counterparty-lib version 9.55.4


#1

Hotfix release v9.55.4

A hotfix for an uncaught exception that could cause Counterparty server to stop has been released today.

There is no mandatory upgrade block for this release. However, all users are encouraged to upgrade as soon as possible.

Upgrade Procedure

Please refer to documentation for deployment mode used in your environment.

  • FedNode: fednode update counterparty. It is recommended to stop services before update, and start them after a successful update. Details can be found in documentation for the fednode utility.
  • Stand-alone counterparty-lib users: stop counterparty-server, use the Python pip utility to install --upgrade counterparty-lib==9.55.4, start counterparty-server.

Source Code