Sweep Private Keys- Issue

Looks like this is working :slight_smile:
But in the command for quantity it is in satoshi, so I had to multiply it by 100000000.
So 31930.214 FLDC = 3193021400000 satoshi

After doing this manually I tried again in Counterwallet to sweep my other coins MAGICFLDC.
This time sweep in counterwallet worked and took only 10 seconds.

1 Like

Hello! I have the same problem. foldinger, can you say what particularly worked for you? Thanks!

In Counterwallet website I could see the altcoins in bitcoin wallet and amounts using the import menu and my bitcoin private compressed wif key but could not import/sweep them successfully.

First I tried it at another day on counterparty website but it did not help.
Then I used manually the instructions from “something” for FLDC coins and the sweep was successful.
After that the counterparty website sweep worked again for another altcoin.

Manually in cmd shell:

  1. use the curl.exe command with source bitcoin adress and destination counterwallet adress, asset type your altcoin “FLDC” and quantity in satoshi, that means multiply your coin value from counterwallet with 100000000

curl.exe --user rpc:1234 -H “Content-Type: application/json; charset=UTF-8” -H “Accept:application/json, text/javascript” --data “{“method”: “create_send”, “params”: { “source”: “1234bitcoinadress5678”, “destination”: “1234counterwalletadress5678”, “asset”: “FLDC”, “quantity”: 3200000000000.0}, “jsonrpc”: “2.0”, “id”: 1 }” http://public.coindaddy.io:4000/api/

=> curl result “0100000001c…”

At bitcoin-qt console
2) signrawtransaction “0100000001c…”
=> sign result “01234…”

  1. sendrawtransaction “01234…”
    => If there was no error message the sweep was triggered successfully

Well, this is really hard for me. Do you think this bug will be fixed?

I don’t know if it will be fixed soon. But as I sucessfully did the manual instructions, I can help you make this more easy.

Do you use Linux or Windows?
Where are your coins now which you want to import to Counterwallet?
Which type of coins is it and how many?

Your help appreciated! I have them on this address 1Dn9BhNTHAPVvJwRfCgJm7i8u3pbvViMoA
I have private key for it. Amount is 1001469.3 FLDC according to counterwallet. And I have BTC on that address also to cover transaction. I use Ubuntu.

  1. Do you already have the private key in compressed WIF format? (Do not post it here!)
  2. In a linux shell is the curl command available?
  3. Is bitcoin-qt installed?
  1. No, I have private key starting with 5
  2. Yes
  3. Just installed and waiting for sync, will take some time I guess

What I can do while it is syning?

Uncompressed private keys (the ‘old’ format) start with a 5

Compressed private keys (the ‘new’ format) start with a K or an L

You need to get the compressed private key.

  1. Goto Bitcoin-qt Console and type
    dumpprivkey 1Dn9BhNTHAPVvJwRfCgJm7i8u3pbvViMoA
    => Your compressed private key starting with K or L

  2. Maybe that compressed private key even works in Counterwallet import successfully?

If not we proceed here.

As I do not have this address in bitcoin-qt I run this command:

importprivkey 5…

then I run

dumpprivkey 1…

but it shows me my imported privkey

Then use the trusted site www.bitaddress.org, ignore the % and click on Wallet Details, where you can paste your 5 private key and get your Private Key WIF Compressed. The conversion is done locally on your PC so nothing is send to www.bitaddress.org

Ok, I have privkey starting with L now. When I paste it to counterwallet it even do not show what is on address. When I paste privkey starting with 5 it showed that there are BTC and Foldingcoin and I can select what to sweep.

Last try before we do the manual steps:

  1. In Counterwallet Import, first paste the 5 key in the form, but do not press the import button
    => available coins are shown
  2. Then replace with the L key
    => available coins are not shown
  3. Click in the empty coins field and the drop down allows you to select the coins again
  4. Now try the import button

Already tried this. Here is the results:

So the manual steps:
@evolution: What is your Counterwallet public FLDC target adress?

I have a private compressed key (start with L), I see the coins in the field correctly, I have BTC for fees. in fact, there were some movements between address of the wallet that you can see 1DWcSApmoYSSQYuD2cshe3U6G1B18ZF7dB , wich allow to think that counterwallet had access to the address and the private key is correctly add… but I have the exaclty same results that evolution with FLDC (i have sjcx)

@bitcoins: In Counterwallet website import you need the 5 private key.

  1. Convert your L private key at www.bitaddress.org to a 5 private key
  2. Try again import at counterwallet website.

Hi! i did what you suggest, but same;
The sweep from address 1LEd… is complete.
Sweep results:

SJCX: Funds not sent due to failure.
This action will take some time to complete, and will appear as a Pending Action until confirmed on the network. Until that time, the wallet will not reflect the change. Please be patient.

then, it is the same result trying WIF and compressed wallets…

OT but related, it is possible to sweep the tokens in different wallet (not at counterwallet?) or it is needed counterwallet to sign any sjcx movements?

@bitcoins: OK then I can help you with the manual console steps to sweep as well.
Do you use Linux or Windows?
What is your coin type and amount?
What is your source public bitcoin address?
What is your target public counterwallet address?